Page 1 of 1

Running a simple cube model

PostPosted: Tue Nov 29, 2016 4:05 pm
by alonso.cubillos
Hi everyone,

I'm running a very simple cubic model with just one top layer of material, just to start modeling different examples apart from the CAN4 that i already succesfully ran. At first i used the same source imput as in CAN4, and computed the seismic response for 4 receivers located at the surface of the basin, but the results it gave me were inconclusive (just a bunch of zeros for the first 0.7 seconds, and then "NaN"). Then i tried using a ramp function increasing linearly from 0 to 1 at 0.5 seconds, but the results were the same. I've tried changing all the source and model parameters i could think of, but i haven't been able to obtain logical results. I'm attaching the input files i'm using, in order to understand the detailed configuration of the model i'm running.
Hope anyone could help me finding a solution!

Best regards,

Re: Running a simple cube model

PostPosted: Thu Jul 06, 2017 12:49 pm
by Hansen
Dear Alonso,

I have been using this 3D code as well. But I encountered the same problem as you stated in the thread (firstly 0 and then NaN). I am wondering whether you have got over this bump or not. If yes, would you like to share with me how you solved this problem?

Thank you with best regards


Re: Running a simple cube model

PostPosted: Mon Jul 10, 2017 2:21 pm
by fdsim
Dear Alonso and Hansen,

sorry for the delayed response.
We checked the input data from Alonso and there is a problem with the number of required MPI processes. Simply your model is too small for 12x10=120 processes.
Your model is 21x21x100 (in the coarser grid) so if PROCX = 12 it means that each MPI process will deal with less than 2 grid planes, which is really two small.

If you use e.g. PROCX = 2, PROCY = 2, PROCZ = 1 (i.e. 4 MPI processes) it should work.

Hansen, please, check this input data.